Wednesday, February 25, 2009

Moved but still not fully functional....

We took a short break from unpacking our belongings this past weekend and headed to Madrid for a long weekend. Scott had a business meeting there this week, so we both went early and then I returned so I could get back to work. I will post photos and recap our nice long weekend there but it may take awhile because we are now in the land of service issue purgatory with our new house. BT has not moved our phone number from our old house to our new house (already a week past when they said they would) and then SKY has cancelled our cable, tv, and Internet subscriptions because we have no current phone line from BT. Neither provider wants to take ownership as to why our services were cancelled so we are having to start a new with everything....which means we are looking at a good two to three weeks before we have any services in our house! 

I am thankfully over at a friend's house tonight to check my email although I am sure they do not want me over at their house every night to use the computer and their vonage phone to call back to the states. Hopefully we will be back up and running in the digital/Internet world soon...oh wait, I mean in due British time.....

1 comment:

notfromaroundhere said...

Ah yes, is anything more inefficient than British telecommunication set-up? I had nightmares on first arrival and the one time I moved, and I think every person I know who has moved has a similar story of delays, miscommunications, and more importantly, NO communications infrastructure for weeks. Sigh.